import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(¶[\\S\\s]*?¶)";
final String string = "This is good text, and should be kept\n\n"
+ "977\n"
+ "00:36:46,805 --> 00:36:50,874\n"
+ "¶ This is complete junk\n"
+ "And this is also junk, on a second line¶\n\n"
+ "This is good, and I want to keep it.\n\n"
+ "¶Garbage on its own line¶\n\n"
+ "This is good\n\n"
+ "Good sentence ¶but rubbish inline¶ and this is good\n\n"
+ "Good\n\n"
+ "¶ Trash\n"
+ "Rubbish ¶\n\n"
+ "Good";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}