// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(¶[\S\s]*?¶)").unwrap();
let string = "This is good text, and should be kept
977
00:36:46,805 --> 00:36:50,874
¶ This is complete junk
And this is also junk, on a second line¶
This is good, and I want to keep it.
¶Garbage on its own line¶
This is good
Good sentence ¶but rubbish inline¶ and this is good
Good
¶ Trash
Rubbish ¶
Good";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}