const regex = /(¶[\S\s]*?¶)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(¶[\\S\\s]*?¶)', 'gm')
const str = `This is good text, and should be kept
977
00:36:46,805 --> 00:36:50,874
¶ This is complete junk
And this is also junk, on a second line¶
This is good, and I want to keep it.
¶Garbage on its own line¶
This is good
Good sentence ¶but rubbish inline¶ and this is good
Good
¶ Trash
Rubbish ¶
Good`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);