# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(¶[\S\s]*?¶)"
test_str = ("This is good text, and should be kept\n\n"
"977\n"
"00:36:46,805 --> 00:36:50,874\n"
"¶ This is complete junk\n"
"And this is also junk, on a second line¶\n\n"
"This is good, and I want to keep it.\n\n"
"¶Garbage on its own line¶\n\n"
"This is good\n\n"
"Good sentence ¶but rubbish inline¶ and this is good\n\n"
"Good\n\n"
"¶ Trash\n"
"Rubbish ¶\n\n"
"Good")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.