re = /(¶[\S\s]*?¶)/m
str = 'This is good text, and should be kept
977
00:36:46,805 --> 00:36:50,874
¶ This is complete junk
And this is also junk, on a second line¶
This is good, and I want to keep it.
¶Garbage on its own line¶
This is good
Good sentence ¶but rubbish inline¶ and this is good
Good
¶ Trash
Rubbish ¶
Good'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result