import Foundation
let pattern = #"(¶[\S\s]*?¶)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
This is good text, and should be kept
977
00:36:46,805 --> 00:36:50,874
¶ This is complete junk
And this is also junk, on a second line¶
This is good, and I want to keep it.
¶Garbage on its own line¶
This is good
Good sentence ¶but rubbish inline¶ and this is good
Good
¶ Trash
Rubbish ¶
Good
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)