# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=admins":[[:space:]]\[)(.*(,[[:space:]]0))(?=\])//g;t' <<< "{
\"admins\": [0, 148, 10, 0, 0, 0, 0, 0, 0, 0, 0],
\"auth\": \"30639096bfe4ec4b9f17696ef1d02b9a\",
}
"