import Foundation
let pattern = #"(?<=admins":[[:space:]]\[)(.*(,[[:space:]]0))(?=\])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{
"admins": [0, 148, 10, 0, 0, 0, 0, 0, 0, 0, 0],
"auth": "30639096bfe4ec4b9f17696ef1d02b9a",
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)