use strict;
my $str = '{
"admins": [0, 148, 10, 0, 0, 0, 0, 0, 0, 0, 0],
"auth": "30639096bfe4ec4b9f17696ef1d02b9a",
}
';
my $regex = qr/(?<=admins":[[:space:]]\[)(.*(,[[:space:]]0))(?=\])/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";