# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=admins\":[[:space:]]\[)(.*(,[[:space:]]0))(?=\])"
test_str = ("{\n"
" \"admins\": [0, 148, 10, 0, 0, 0, 0, 0, 0, 0, 0],\n"
" \"auth\": \"30639096bfe4ec4b9f17696ef1d02b9a\",\n"
"}\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.