import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=admins\":[[:space:]]\\[)(.*(,[[:space:]]0))(?=\\])";
final String string = "{\n"
+ " \"admins\": [0, 148, 10, 0, 0, 0, 0, 0, 0, 0, 0],\n"
+ " \"auth\": \"30639096bfe4ec4b9f17696ef1d02b9a\",\n"
+ "}\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}