using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=admins"":[[:space:]]\[)(.*(,[[:space:]]0))(?=\])";
string substitution = @"";
string input = @"{
""admins"": [0, 148, 10, 0, 0, 0, 0, 0, 0, 0, 0],
""auth"": ""30639096bfe4ec4b9f17696ef1d02b9a"",
}
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}