use strict;
my $str = '
int a, ss, f ;
char g;
byte f_123 ; double pi;
String string;
Object[] array1;
int [] array2, array3;';
my $regex = qr/\s*(byte|short|int|long|float|double|char|boolean|[A-Z][a-zA-z]+)\s*(\[\])*\s+([\w]+)\s*((,\s*[\w]+)*)\s*;/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}