import re
regex = re.compile(r"\s*(byte|short|int|long|float|double|char|boolean|[A-Z][a-zA-z]+)\s*(\[\])*\s+([\w]+)\s*((,\s*[\w]+)*)\s*;", flags=re.MULTILINE)
test_str = ("\n"
"int a, ss, f ;\n"
"char g;\n"
"byte f_123 ; double pi;\n"
"String string;\n\n"
"Object[] array1;\n"
"int [] array2, array3;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")