re = /\s*(byte|short|int|long|float|double|char|boolean|[A-Z][a-zA-z]+)\s*(\[\])*\s+([\w]+)\s*((,\s*[\w]+)*)\s*;/m
str = '
int a, ss, f ;
char g;
byte f_123 ; double pi;
String string;
Object[] array1;
int [] array2, array3;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end