import Foundation
let pattern = #"\s*(byte|short|int|long|float|double|char|boolean|[A-Z][a-zA-z]+)\s*(\[\])*\s+([\w]+)\s*((,\s*[\w]+)*)\s*;"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
int a, ss, f ;
char g;
byte f_123 ; double pi;
String string;
Object[] array1;
int [] array2, array3;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)