#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d{1}[.,]\d{2}"
Local $sString = "9.78" & @CRLF & _
"6.54" & @CRLF & _
"3,12" & @CRLF & _
"1,00" & @CRLF & _
"0,00" & @CRLF & _
"" & @CRLF & _
"123" & @CRLF & _
"123,56" & @CRLF & _
"123.78" & @CRLF & _
"0,12232" & @CRLF & _
".90" & @CRLF & _
"-342" & @CRLF & _
"" & @CRLF & _
"\d+?[\.\,]?\d+"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")