re = /\d{1}[.,]\d{2}/
str = '9.78
6.54
3,12
1,00
0,00
123
123,56
123.78
0,12232
.90
-342
\\d+?[\\.\\,]?\\d+'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end