import Foundation
let pattern = #"\d{1}[.,]\d{2}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
9.78
6.54
3,12
1,00
0,00
123
123,56
123.78
0,12232
.90
-342
\d+?[\.\,]?\d+
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)