using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{1}[.,]\d{2}";
string input = @"9.78
6.54
3,12
1,00
0,00
123
123,56
123.78
0,12232
.90
-342
\d+?[\.\,]?\d+";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}