import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{1}[.,]\\d{2}";
final String string = "9.78\n"
+ "6.54\n"
+ "3,12\n"
+ "1,00\n"
+ "0,00\n\n"
+ "123\n"
+ "123,56\n"
+ "123.78\n"
+ "0,12232\n"
+ ".90\n"
+ "-342\n\n"
+ "\\d+?[\\.\\,]?\\d+";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}