const regex = /\d{1}[.,]\d{2}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{1}[.,]\\d{2}', 'g')
const str = `9.78
6.54
3,12
1,00
0,00
123
123,56
123.78
0,12232
.90
-342
\\d+?[\\.\\,]?\\d+`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}