using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(hello)\n*(world)";
string input = @" a0
b0
c0
hello
a1
b1
c1
world
more...
hello
a2
b2
c2
world
a3
b3
c3
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}