import re
regex = re.compile(r"(hello)\n*(world)", flags=re.MULTILINE)
test_str = (" a0\n"
" b0\n"
" c0\n"
"hello\n"
" a1\n"
" b1\n"
" c1\n"
"world\n"
"more...\n"
"hello\n"
" a2\n"
" b2\n"
" c2\n"
"world\n"
" a3\n"
" b3\n"
" c3\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")