$re = '/(hello)\n*(world)/m';
$str = ' a0
b0
c0
hello
a1
b1
c1
world
more...
hello
a2
b2
c2
world
a3
b3
c3
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);