const regex = /(hello)\n*(world)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(hello)\\n*(world)', 'gm')
const str = ` a0
b0
c0
hello
a1
b1
c1
world
more...
hello
a2
b2
c2
world
a3
b3
c3
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}