re = /(hello)\n*(world)/m
str = ' a0
b0
c0
hello
a1
b1
c1
world
more...
hello
a2
b2
c2
world
a3
b3
c3
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end