#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*(\d+\..*(?:\n@.*)+)"
Local $sString = "1. @aut1.or" & @CRLF & _
"@Autowired" & @CRLF & _
"2. @Override" & @CRLF & _
"@param" & @CRLF & _
"@SuppressWarnings" & @CRLF & _
" 3. @aut1.or" & @CRLF & _
"@Autowired"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")