re = /^\s*(\d+\..*(?:\n@.*)+)/m
str = '1. @aut1.or
@Autowired
2. @Override
@param
@SuppressWarnings
3. @aut1.or
@Autowired'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end