package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*(\d+\..*(?:\n@.*)+)`)
var str = `1. @aut1.or
@Autowired
2. @Override
@param
@SuppressWarnings
3. @aut1.or
@Autowired`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}