using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(\d+\..*(?:\n@.*)+)";
string input = @"1. @aut1.or
@Autowired
2. @Override
@param
@SuppressWarnings
3. @aut1.or
@Autowired";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}