$re = '/^\s*(\d+\..*(?:\n@.*)+)/m';
$str = '1. @aut1.or
@Autowired
2. @Override
@param
@SuppressWarnings
  3. @aut1.or
@Autowired';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);