// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*(\d+\..*(?:\n@.*)+)").unwrap();
let string = "1. @aut1.or
@Autowired
2. @Override
@param
@SuppressWarnings
3. @aut1.or
@Autowired";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}