package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\n[-:;=""\/\.\sa-zA-Z]+\n\n`)
var str = `
Content-Disposition: form-data; name="file"; filename="test.jpg"
Content-Type: image/jpeg
тут тело картинки
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}