const regex = /\n[-:;=""\/\.\sa-zA-Z]+\n\n/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\n[-:;=""\\\/\\.\\sa-zA-Z]+\\n\\n', 'gi')
const str = `
Content-Disposition: form-data; name="file"; filename="test.jpg"
Content-Type: image/jpeg
тут тело картинки
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}