using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^,],){2}(([^,],){4}).*";
string substitution = @"$2";
string input = @"a,b,c,d,e,f,g,h,i,j,k,l";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}