use strict;
my $str = 'a,b,c,d,e,f,g,h,i,j,k,l';
my $regex = qr/([^,],){2}(([^,],){4}).*/mp;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";