re = /([^,],){2}(([^,],){4}).*/m
str = 'a,b,c,d,e,f,g,h,i,j,k,l'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result