$re = '/([^,],){2}(([^,],){4}).*/m';
$str = 'a,b,c,d,e,f,g,h,i,j,k,l';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;