#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\b|(?<=[a-z]))(?:ShFrm|LgFrm|Auto)(?=[A-Z]|\b)"
Local $sString = "ShFrmLgFrm should be replaced Automatically" & @CRLF & _
"Auto" & @CRLF & _
"AutoLgFrm"
Local $sSubst = "<match>\g<0></match>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)