const regex = new RegExp('(?:\\b|(?<=[a-z]))(?:ShFrm|LgFrm|Auto)(?=[A-Z]|\\b)', 'gm')
const str = `ShFrmLgFrm should be replaced Automatically
Auto
AutoLgFrm`;
const subst = `<match>\g<0></match>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);