import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\b|(?<=[a-z]))(?:ShFrm|LgFrm|Auto)(?=[A-Z]|\\b)";
final String string = "ShFrmLgFrm should be replaced Automatically\n"
+ "Auto\n"
+ "AutoLgFrm";
final String subst = "<match>\\g<0></match>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}