re = /(?:\b|(?<=[a-z]))(?:ShFrm|LgFrm|Auto)(?=[A-Z]|\b)/m
str = 'ShFrmLgFrm should be replaced Automatically
Auto
AutoLgFrm'
subst = '<match>\\g<0></match>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result