import Foundation
let pattern = #"(?:\b|(?<=[a-z]))(?:ShFrm|LgFrm|Auto)(?=[A-Z]|\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ShFrmLgFrm should be replaced Automatically
Auto
AutoLgFrm
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<match>\g<0></match>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)