use strict;
my $str = 'ShFrmLgFrm should be replaced Automatically
Auto
AutoLgFrm';
my $regex = qr/(?:\b|(?<=[a-z]))(?:ShFrm|LgFrm|Auto)(?=[A-Z]|\b)/mp;
my $subst = '<match>\\g<0></match>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";