const regex = /\d+[a-zA-Z]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+[a-zA-Z]', 'gm')
const str = `Service code 145b is used for.
...you are to use code 99a.
Service code 32d is used for.
...you are to use code 119z.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}