// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+[a-zA-Z]").unwrap();
let string = "Service code 145b is used for.
...you are to use code 99a.
Service code 32d is used for.
...you are to use code 119z.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}