import re
regex = re.compile(r"\d+[a-zA-Z]", flags=re.MULTILINE)
test_str = ("Service code 145b is used for.\n"
"...you are to use code 99a.\n"
"Service code 32d is used for.\n"
"...you are to use code 119z.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")