re = /((\W+?)?)((\w+?)?)(([aeiou|AEIOU]+?)?)(\w+?)(\W+?)/mx
str = '"When I went to school, they asked me what I wanted to be when I grew up. I wrote down "Happy." They told me I didn\'t understand the assignment, and I told them they didn\'t understand every life."
'
subst = '\\7\\4ay '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result