// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)((\W+?)?)((\w+?)?)(([aeiou|AEIOU]+?)?)(\w+?)(\W+?)").unwrap();
let string = "\"When I went to school, they asked me what I wanted to be when I grew up. I wrote down \"Happy.\" They told me I didn't understand the assignment, and I told them they didn't understand every life.\"
";
let substitution = "\\7\\4ay ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}